Author Topic: 1LTC reward, need working config 2xHD7950 + 1x r9 280x  (Read 11922 times)

0 Members and 1 Guest are viewing this topic.

Offline apoftelbrauTopic starter

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
1LTC reward, need working config 2xHD7950 + 1x r9 280x
« on: December 03, 2013, 04:48:58 AM »
hi,


my brother for xmas wanted a mining rig, so i built him one with the graphics cards in the topic. In the past i've only built gaming rigs for myself.


Basically atm I just have two HD7950's in the rig, and i'm getting about 560 hash out of each. If i try to reach for 600 hash (my goal for those two cards) I end up with my gpu being 80c (my ambient temps are absolutely freezing, like 5c. The HD7950's are powercolor PC+.


Could someone please suggest a config that would work with cgminer? I've tried to use examples found on the internet, these forums but often my amd driver (latest beta) crashes or cgminer crashes. I'm offering 1LTC to whoever can help me asap, because without help the rig won't be mining, and in a few hours i'll have an r9 280x so a day and a bit of missed mining without help = about 1 LTC.

Currently,


gpu 0 settings: engine 986, mem 1250, powertune 20, intensity 20, vddc (shown in cgminer 1.090V) = 561 hash
gpu 1 settings: engine 986, mem 1250, power tune 20, intensity 20, vddc (same as above)= 565 hash

both tc 24000

however I input those values by starting cgminer and pressing g then c, not by using a config file. Temps both cards atm 73c and 72c at about 1500rpm fan.

Thanks.
« Last Edit: December 03, 2013, 05:45:18 AM by apoftelbrau »


Offline apoftelbrauTopic starter

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: 1LTC reward, need working config 2xHD7950 + 1x r9 280x
« Reply #1 on: December 03, 2013, 04:57:42 AM »
I also have amd sdk 2.9 installed, plus windows updates. I don't want to have to use msi afterburner or anything, rather the core, mem, vddc be all set via the config.  :)

Offline apoftelbrauTopic starter

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: 1LTC reward, need working config 2xHD7950 + 1x r9 280x
« Reply #2 on: December 03, 2013, 05:01:58 AM »
He doesn't have to pay electricity costs, his company pays for those... so its not efficiency that is uber important, just would like to be close to 600 hash per card without insane temps, and a stable setup which doesn't crash cgminer.

Offline apoftelbrauTopic starter

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: 1LTC reward, need working config 2xHD7950 + 1x r9 280x
« Reply #3 on: December 03, 2013, 10:37:28 AM »
All 3 cards are stuck at 150/300 clocks atm. No idea what to do. 1LTC is waiting!

Offline jdevers

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: 1LTC reward, need working config 2xHD7950 + 1x r9 280x
« Reply #4 on: December 04, 2013, 01:07:08 PM »
What are your fan settings like?  What is case airflow?  Try turning intensity down to 15-16 and see from there.  Try with just one card.  Lots of variables here that can't be accounted for with your listed information.  Have your tweaked the thread concurrency?

Offline pengo

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 1LTC reward, need working config 2xHD7950 + 1x r9 280x
« Reply #5 on: December 10, 2013, 07:37:17 AM »
On my Sapphire DualX 7950 I use BFGMiner  v3.2.8 (newer version missreport the hash rate).
 
 Hash rate = 550 kH/sec @ 69C
 Power usage = 250w (PC)
 
 Latest beta vga driver (R9 280X on order)
 AMD SDK v2.9
 MSI Afterburner v3.0.0 beta 17
 
 GPU Clock 955
 GPU Voltage 1013
 Mem Clock 1500
 Mem Voltage 1513
 Powertune +20
« Last Edit: December 10, 2013, 11:31:26 AM by pengo »

Offline xLightcoinx

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: 1LTC reward, need working config 2xHD7950 + 1x r9 280x
« Reply #6 on: December 14, 2013, 09:59:31 PM »
....

Hi,

I'm finding myself in the same situation. I had 2 HD7950's and got my hands on a R9 280X, all XFX. Turns out that the 280x runs best using gpu-threads setting 2 and the HD7950's on gpu-threads 1. As this is a global setting per cgminer setting you can specify it in one go. However when I launch seperate instances of cgminer with this distinction my overal performance on all cards drops by 100 to 150Khs.

At the moment I settled for best performance for the HD7950 (around 640Khs) and below par (540Khs) for the 280x. I'm running Linux Xubuntu and cgminer 2.11.4.

If anyone has suggestions I'm all ears. In the meantime current config for my setup is :

Code: [Select]
"intensity" : "19,19,13",
"vectors" : "1,1,1",
"kernel" : "scrypt",
"worksize" : "256,256,256",
"thread-concurrency" : "24000,24000,8192",
"gpu-engine" : "1110,1110,1026",
"gpu-fan" : "30-85,30-85,30-85",
"gpu-memclock" : "1575,1575,1498",
"gpu-powertune" : "20,20,5",
"temp-cutoff" : "90,90,90",
"temp-overheat" : "85,85,85",
"temp-target" : "80,80,80",
"api-port" : "4028",
"api-listen" : true,
"api-network" : true,
"auto-fan" : true,
"auto-gpu" : true,
"no-submit-stale" : true,
"log" : "5",
"failover-only" : true,
"scan-time" : "30",
"scrypt" : true,
"kernel-path" : "/usr/local/bin"

Edit : Cards 1 and 2 are the XFX HD7950's and the 3rd one is the XFX R9 280X.

Code: [Select]
  p, li { white-space: pre-wrap; } --------------------------------------------------------------------------------
 [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 0:  77.0C 3074RPM | 627.8K/630.4Kh/s | A:735 R:6 HW:0 U:17.99/m I:19
 GPU 1:  78.0C  62%    | 627.3K/634.9Kh/s | A:787 R:3 HW:0 U:19.26/m I:19
 GPU 2:  77.0C 1352RPM | 556.9K/538.3Kh/s | A:634 R:3 HW:0 U:15.52/m I:13
--------------------------------------------------------------------------------
« Last Edit: December 14, 2013, 10:05:40 PM by xLightcoinx »

Offline xLightcoinx

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: 1LTC reward, need working config 2xHD7950 + 1x r9 280x
« Reply #7 on: December 15, 2013, 11:14:35 AM »
Right, I found a workaround which isn't as good as I wanted too but it will do for now. It is ugly in monitoring too, but ok, I need the hashes for the money these cards cost.

I setup 2 workers in the pools I mine for. I also launch 2 cgminer processes now, not using a jason stile config, but in command line format. This because I wasn able to address the 2 HD7950's in 1 config file. The device option didn't allow for 2 GPU's.

So I have a script that calls 2 other scripts to start the different cards into screen sessions like below. First line uses "-d 0 -d 1" to call the first two cards being the HD7950's using worker1. The 2nd line uses -d 2 to call the R9 280X using worker2:

cgminer.sh
Code: [Select]

find *.bin -delete
sleep 2
# Start HD7950s
screen -dmS cgm0 ./cgminer.hd7950.sh
sleep 2
# Start R9 280X
screen -dmS cgm1 ./cgminer.r9-280x.sh

cgminer.hd7950.sh
Code: [Select]

export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=100
export DISPLAY=:0
#
# Start HD7950s
screen -dmS cgm0 ./cgminer --scrypt -o <url> -u worker1 -p xyz --failover-only -o <url> -u worker1 -p 456 -d 0 -d 1 -I 19 -w 256 --thread-concurrency 24000 --gpu-powertune 20 -v 1 --gpu-engine 1110 --gpu-memclock 1575 --auto-fan --auto-gpu --no-submit-stale --scan-time 30 --shaders 1792 --gpu-fan 30-85 --temp-cutoff 90 --temp-overheat 85 --temp-target 80 --api-port 4028 --api-listen --api-network



cgminer.r9-280x.sh
Code: [Select]

export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=100
export DISPLAY=:0
#
#Start 280x
screen -dmS cgm1 ./cgminer --scrypt -o <url> -u worker2 -p xyz --failover-only -o <url> -u worker2 -p 456  -d 2 -I 13 -g 2 -w 256 --thread-concurrency 8192 --gpu-powertune 5 -v 1 --gpu-engine 1026 --gpu-memclock 1498 --auto-fan --auto-gpu --no-submit-stale --scan-time 30 --shaders -2048 --gpu-fan 30-85 --temp-cutoff 90 --temp-overheat 85 --temp-target 80 --api-port 4029 --api-listen --api-network


This way I get 610+ Khs for the 2 XFX 7950's each and 700+ Khs for the XFX R9 280X, for a total of around 1900+ Khs in total. I'm sure there is some hashes to be gained by a litle tweaking from here onward, but ok enough.

Code: [Select]

--------------------------------------------------------------------------------
 [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 0:  79.0C 3322RPM | 626.3K/618.4Kh/s | A:107 R:3 HW:0 U:  4.82/m I:19
 GPU 1:  78.0C  70%    | 627.5K/618.8Kh/s | A:119 R:4 HW:0 U:  5.36/m I:19
 GPU 2:  77.0C 1798RPM | OFF   / 0.000h/s | A:  0 R:0 HW:0 U:  0.00/m I:19
--------------------------------------------------------------------------------


Code: [Select]

--------------------------------------------------------------------------------
 [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 0:  79.0C 3324RPM | OFF   / 81.00h/s | A:  0 R:0 HW:0 U:  0.00/m I:13
 GPU 1:  78.0C  70%    | OFF   / 0.000h/s | A:  0 R:0 HW:0 U:  0.00/m I:13
 GPU 2:  77.0C 1797RPM | 730.4K/710.5Kh/s | A:364 R:1 HW:0 U: 16.67/m I:13
--------------------------------------------------------------------------------
« Last Edit: December 15, 2013, 04:47:42 PM by xLightcoinx »

Offline xLightcoinx

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: 1LTC reward, need working config 2xHD7950 + 1x r9 280x
« Reply #8 on: December 23, 2013, 01:53:28 PM »
Should anyone read this, in the above setup I had issues with (I think) the ATI drivers. I would start cgminer process 1 all fine. Starting cgminer process 2 afterwards and settings between the 2 would get mangled. I added the "--remove-disabled" option to both startups and I'm getting better performance because both processes don't interfere with eachother anymore.

So  :
cgminer.hd7950.sh becomes :

Code: [Select]

export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=100
export DISPLAY=:0
#
# Start HD7950s
screen -dmS cgm0 ./cgminer --scrypt -o <url> -u worker1 -p xyz --failover-only -o <url> -u worker1 -p 456 -d 0 -d 1 --remove-disabled -I 19 -w 256 --thread-concurrency 24000 --gpu-powertune 20 -v 1 --gpu-engine 1110 --gpu-memclock 1575 --auto-fan --auto-gpu --no-submit-stale --scan-time 30 --gpu-fan 30-85 --temp-cutoff 90 --temp-overheat 85 --temp-target 80 --api-port 4028 --api-listen --api-network


cgminer.r9-280x.sh becomes :
Code: [Select]

export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=100
export DISPLAY=:0
#
#Start 280x
screen -dmS cgm1 ./cgminer --scrypt -o <url> -u worker2 -p xyz --failover-only -o <url> -u worker2 -p 456  -d 2 --remove-disabled -I 13 -g 2 -w 256 --thread-concurrency 8192 --gpu-powertune 5 -v 1 --gpu-engine 1026 --gpu-memclock 1498 --auto-fan --auto-gpu --no-submit-stale --scan-time 30 --gpu-fan 30-85 --temp-cutoff 90 --temp-overheat 85 --temp-target 80 --api-port 4029 --api-listen --api-network

With these settings i get 650+ each on my XFX HD7950's and 710+ on my XFX R9 280x.

XFX HD7950's
Code: [Select]
[P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 0:  78.0C 3515RPM | 652.0K/648.8Kh/s | A:92 R:1 HW:0 U:  2.74/m I:19
 GPU 1:  77.0C 2920RPM | 653.6K/650.6Kh/s | A:88 R:0 HW:0 U:  2.62/m I:19

XFX 280x :
Code: [Select]
[P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 2:  78.0C 1614RPM | 730.7K/711.3Kh/s | A:1135 R:109 HW:0 U:36.49/m I:13
« Last Edit: December 23, 2013, 02:02:51 PM by xLightcoinx »

 

Third Graphics Card NOT WORKING 7970 + 7970 + 280x.

Started by chriscantrell1989Board Litecoin mining

Replies: 0
Views: 1677
Last post December 14, 2013, 01:43:37 AM
by chriscantrell1989
cgEasy v1.0.1--Generate CGminer config for LTC Mining easy!

Started by rTechBoard Litecoin mining

Replies: 1
Views: 63631
Last post March 06, 2013, 11:05:27 AM
by Silky Jackson
Solo Mining - Is it working and how long?

Started by jdwlupineBoard Newbies

Replies: 2
Views: 20669
Last post July 27, 2013, 06:33:39 PM
by grapemon1611
Boost my Khash rate and get a reward.

Started by gemaalpadBoard Litecoin mining

Replies: 0
Views: 4052
Last post May 04, 2013, 01:35:29 AM
by gemaalpad
7950 or R9 280X ?

Started by MangodreamBoard Litecoin mining

Replies: 1
Views: 8178
Last post November 16, 2013, 11:00:38 PM
by ozzysosa