Author Topic: cgminer + ksoftirqd 100% CPU usage  (Read 11890 times)

0 Members and 1 Guest are viewing this topic.

Offline mzahorTopic starter

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
cgminer + ksoftirqd 100% CPU usage
« on: September 01, 2013, 12:19:47 PM »
Hi Guys,


I've Xubuntu 13.04 running cgminer with radeon 7950 and 7970.  Cgminer 3.3.1 + ksoftirqd  use 100% CPU. One of the card is mining with nice hashrate and second very very low hash rate. It seem's to be some interrupt problem - ksoftirqd is unable to handle that IRQ storm.  I have 4GB RAM. DMESG shows no problems


Thanx, Michal





Offline kentt

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: cgminer + ksoftirqd 100% CPU usage
« Reply #1 on: September 16, 2013, 05:07:33 PM »
Did you find a resolution to this.  I have the same problem.  The difference from your setup are
xubuntu 12.04
6x7950s with all great hashrates
20 GB ram
CGminer 3.4.2

Offline santyor

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: cgminer + ksoftirqd 100% CPU usage
« Reply #2 on: November 13, 2013, 11:29:03 PM »
Hey, I have this issue too with Linux Mint (ubuntu 13.04), cgminer version 3.7.2, R9 280X. Actually hard to say if that's the issue, cause system is responsive. Script is not supported by cgminer anymore, so any help appreciate.

Offline sveddi

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: cgminer + ksoftirqd 100% CPU usage
« Reply #3 on: January 11, 2014, 04:47:35 PM »
Hi Guys,


i got a solution for this problem.


The problem is the AMD Graphic Card Driver which causes a lots of interrups.


 cat /proc/interrupts    shows the problem...


The solution is to update the AMD GPU driver.  Catalyst 13.12 works fine.  No ksoftirqd issues.


i have ubuntu 13.10  (saucy)


ps: installung the driver is not that easy but possible ^^ ;)   
You have to fix the AMD driver :D   --> newbielink:http://phoronix.com/forums/showthread.php?91885-AMD-Catalyst-13-12-GPU-Driver-For-Linux-Released&p=382324#post382324 [nonactive]

Offline wpcodr

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 4
  • Country: 00
  • Karma: +1/-0
    • View Profile
Re: cgminer + ksoftirqd 100% CPU usage
« Reply #4 on: January 21, 2014, 03:32:21 PM »
Anyone have any new ideas on this? I still have this problem.

I tried using Saucy 13.10 and the LTS Precise 12.04. Neither the 13.11 or 13.12 Catalyst drivers work under any version of Ubuntu I have tried. They all get high ksoftirqd load when mining.

If I disable multiple processors (kernel option maxcpus=1) then it works fine, 0% CPU load but when I enable multiple cores ksoftirqd and cgminer load the machine down heavily and it DOES affect the performance of the system and the mining rate (fairly significantly in fact).

When using nVidia there is 0% CPU load when mining. It's definitely the Catalyst driver that is having problems.

I'm using a Q87M-E motherboard and Haswell processor. Not sure if maybe a BIOS setting could help.
BTC: 1HvrdHrvKaG9pfreJxJkF2Ym6HAuwQ6suQ

Offline wpcodr

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 4
  • Country: 00
  • Karma: +1/-0
    • View Profile
Re: cgminer + ksoftirqd 100% CPU usage
« Reply #5 on: February 02, 2014, 04:45:33 PM »
Tried latest 14.1 Beta Catalyst driver... still broken  :(

Not getting anywhere with this one unforetunately.
BTC: 1HvrdHrvKaG9pfreJxJkF2Ym6HAuwQ6suQ

Offline wpcodr

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 4
  • Country: 00
  • Karma: +1/-0
    • View Profile
Re: cgminer + ksoftirqd 100% CPU usage
« Reply #6 on: February 04, 2014, 06:54:59 PM »
Built a new machine. This time using an older B75 board and Celeron and different video cards. Exact same problem.  >:(
BTC: 1HvrdHrvKaG9pfreJxJkF2Ym6HAuwQ6suQ

Offline Tempest

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: cgminer + ksoftirqd 100% CPU usage
« Reply #7 on: February 09, 2014, 07:44:51 PM »
Same problem here. Using Xubuntu 12.04, 2x7950, Catalyst 13.12 and tried with 3 different boards (AMD/Intel).

Setting maxcpus=1 did help here also, but I really hope this issue gets resolved in the future...
« Last Edit: February 09, 2014, 08:03:26 PM by Tempest »

Offline wpcodr

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 4
  • Country: 00
  • Karma: +1/-0
    • View Profile
Re: cgminer + ksoftirqd 100% CPU usage
« Reply #8 on: February 20, 2014, 12:09:08 PM »
FINALLY figured out what the problem is. Ugh...  ::)

The problem is that the AMD APP SDK's version of libOpenCL is broken and if you have it installed you will get the ksoftirqd irq storm. The APP SDK adds itself to the library path and overrides the correct libOpenCL from whatever driver you have installed.

There are a bunch of ways to solve this (including just uninstalling the SDK) but what I did was edit my ".profile" (or ".bashrc") and add to the end:
Code: newbielink:javascript:void(0); [nonactive]
export LD_LIBRARY_PATH=/usr/lib/fglrx:$LD_LIBRARY_PATH
Or do it however you like. The APP SDK modifies "/etc/profile" and adds "/etc/ld.so.conf.d/amdapp_*" files. The key is to use the libOpenCL from the fglrx driver install. You can use "ldd cgminer" to see which libOpenCL it's going to use.

You may have to delete any of the *.bin files that cgminer has created and let it compile new ones but I did not need to.  Now it runs with 0% CPU load and I can run with all cores enabled.
« Last Edit: February 20, 2014, 12:25:16 PM by wpcodr »
BTC: 1HvrdHrvKaG9pfreJxJkF2Ym6HAuwQ6suQ

Offline Tempest

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: cgminer + ksoftirqd 100% CPU usage
« Reply #9 on: February 22, 2014, 11:21:17 AM »
You found the issue, many thanks wpcodr !!

My solution is to add
export LD_LIBRARY_PATH=/usr/lib/fglrx:$LD_LIBRARY_PATH

to my cgminer startup script, because it also works with automated startup via /etc/rc.local

Thanks again, I can start using cpumining now ;-)


 

Mining tools (cpu/gpu)

Started by rTechBoard Litecoin mining

Replies: 0
Views: 60057
Last post December 30, 2012, 05:09:06 PM
by rTech
cgEasy v1.0.1--Generate CGminer config for LTC Mining easy!

Started by rTechBoard Litecoin mining

Replies: 1
Views: 63554
Last post March 06, 2013, 11:05:27 AM
by Silky Jackson
New CGMiner Released!

Started by btc4lyfeBoard Litecoin mining

Replies: 2
Views: 8263
Last post April 25, 2013, 04:30:58 AM
by alinsaviuc
Cgminer download

Started by NeedLitecoinBoard Litecoin mining

Replies: 0
Views: 3182
Last post August 18, 2014, 04:38:57 AM
by NeedLitecoin
cgminer: socks proxy function fail since 3.1.1

Started by SchlumbinatorBoard Litecoin mining

Replies: 0
Views: 5137
Last post August 15, 2013, 08:19:35 AM
by Schlumbinator