Author Topic: Mining speed too slow with 2x XFX 280x  (Read 28400 times)

0 Members and 1 Guest are viewing this topic.

Offline jpvainTopic starter

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Mining speed too slow with 2x XFX 280x
« on: December 01, 2013, 02:00:56 PM »
Hi, so I bought 2x XFX r9 280x black edition for mining, and have had mining speeds for about 550kh/s for each card. I've read that 280x cards should get over 700kh/s, so what could be the problem here? Using cgminer and tried versions 3.5 and 3.7.2, both with same results.


Here is my current cgminer.conf file:



{
"pools" : [
   {
      "url" : "stratum+tcp://eu.ltcrabbit.com:3333",
      "user" : "username",
      "pass" : "password"
   }
]
,
"intensity" : "13,13",
"vectors" : "1,1",
"worksize" : "256,256",
"kernel" : "scrypt,scrypt",
"lookup-gap" : "2,2",
"thread-concurrency" : "8192,8192",
"shaders" : "2048,2048",
"gpu-engine" : "0-0,0-0",
"gpu-fan" : "0-100,0-100",
"gpu-memclock" : "0,0",
"gpu-memdiff" : "0,0",
"gpu-powertune" : "0,0",
"gpu-vddc" : "0.000,0.000",
"temp-cutoff" : "95,95",
"temp-overheat" : "85,85",
"temp-target" : "75,75",
"api-mcast-port" : "4028",
"api-port" : "4028",
"expiry" : "120",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "1",
"hotplug" : "5",
"log" : "5",
"no-pool-disable" : true,
"queue" : "0",
"scan-time" : "30",
"scrypt" : true,
"temp-hysteresis" : "3",
"shares" : "0",
"kernel-path" : "/usr/local/bin"
}


Offline suprememilo

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #1 on: December 05, 2013, 03:18:27 AM »
Ever figure this out?  I got the same card today and first try is around 570...

Offline suprememilo

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #2 on: December 05, 2013, 05:52:56 AM »
here you go - - - - thanks to newbielink:http://www.reddit.com/user/ArizonaBaySC [nonactive] on reddit!!! newbielink:http://www.reddit.com/r/litecoinmining/comments/1rqcy8/r9_290_vs_r9_280x/cdt7t4c?context=3 [nonactive]


getting 705 kH/s




setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer.exe --scrypt -o stratum+tcp://server.fart -u username.1-p password --lookup-gap 2 --thread-concurrency 8192 -g 2 -I 13 -w 256 --auto-fan --gpu-memclock 1500,1500 --gpu-engine 1020,1020 --gpu-powertune -20,-20 --expiry 1 --scan-time 1 --queue 0 --no-submit-stale

Offline varenik

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #3 on: December 06, 2013, 02:45:02 PM »
This config seems for Gigabyte cards. I'm getting ~590kH/s max using these settings.

Offline grunf16

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #4 on: December 08, 2013, 12:57:51 AM »
If yours XFX bios version is 39 or lower need to upgrade it to version 40. Then it can go over 700...
And change

"gpu-threads" : "1",

to

"gpu-threads" : "2",
« Last Edit: December 08, 2013, 10:22:29 AM by grunf16 »

Offline jackcrowley

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 3
  • Country: 00
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #5 on: December 09, 2013, 06:16:55 AM »
If yours XFX bios version is 39 or lower need to upgrade it to version 40. Then it can go over 700...
And change

"gpu-threads" : "1",

to

"gpu-threads" : "2",

Where do you find the XFX version 40 bios? I've been searching for hours now with no luck.

Offline hkust

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #6 on: December 13, 2013, 01:52:17 PM »
Did the OP ever get better results? I have the same cards and average ~455Kh/s per card. I tried different config settings but don't see any significant difference in output. Any ideas?

The cards have the latest firmware

The environment is set up with



export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=100


and cgminer just loads the current config below



"intensity" : "17,17",
"vectors" : "1,1",
"worksize" : "256,256",
"kernel" : "scrypt,scrypt",
"lookup-gap" : "2,2",
"thread-concurrency" : "11200,11200",
"shaders" : "2048,2048",
"gpu-engine" : "1080,1080",
"gpu-fan" : "65-100,65-100",
"gpu-memclock" : "1500,1500",
"gpu-memdiff" : "0,0",
"gpu-powertune" : "-20,-20",
"gpu-vddc" : "0.000,0.000",
"temp-cutoff" : "95,95",
"temp-overheat" : "85,85",
"temp-target" : "75,75",
"auto-fan" : true,
"api-port" : "4028",
"expiry" : "1",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "2",
"hotplug" : "5",
"log" : "5",
"no-pool-disable" : true,
"queue" : "0",
"scan-time" : "1",
"scrypt" : true,
"temp-hysteresis" : "3",
"shares" : "0",
"load-balance" : true,
"kernel-path" : "/usr/local/bin"
« Last Edit: December 13, 2013, 05:12:47 PM by hkust »

Offline jackcrowley

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 3
  • Country: 00
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #7 on: December 13, 2013, 11:41:35 PM »
These cards are so dmn fussy. My results for this card are below.

You have to get the settings down to the exact MH core clock to get optimal, reliable results and even then you'll get only 650 tops average.

I found using bamt wasn't the best, but using ltcrabbit gives pretty decent speeds. I think the version of the drivers/etc on rabbit are more well suited to the xfx card.  I've heard that windows mining can get decent speeds too, but I couldn't find a decent combination of the drivers/etc to give a decent speed with this card.

I tried flashing the bios from other manufacturers too, my results are:
MSI - doesn't have any image on the display after flashing at all
Sapphire dual-x oc - black screen in windows/linux gui
HIS ipower iceq - no image output at all
Gigabyte - horrible. Took multiple attempts to restore to usable bios and no output

I did try a few others too, but no other manufacturers bios works. The comment about using "version 40" which would be 015.040.000.0000 is not relevant, as there is no such version available anywhere and xfx do not supply a bios if you ask them. You can make sure your card is 015.039.000.0000 if not then updating at techpowerup. Do not try flashing another manufacturer version 015.040 or your card will be bricked and you'll have to do a blind restoration. Maybe they'll update their firmware but so far going through their support team has been fruitless.


Once you have ltcrabbit up and running though with these cards, tune the correct core speed you should get a reliable 650 MH/s with it. for two cards I had the following settings:

intensity 20
worksize 256
temp-cutoff 90
temp-overheat 85
temp-target 80                         (these cards are okay running hot)
expiry 30
gpu-dyninterval 7
queue 1
scan-time 30
temp-hysteresis 3
shaders 2048
thread concurrency 24200
gpu-threads 1                          (no discernable diff between 1 and 2 with this bios)
gpu engine - tuned for each card, 1048 for one, 1053 for another
sharethreads 32
gpu-powertune 20
gpu-memclock 1500

This runs around 80 degrees constantly. I get 640-680MH/s but generally it sits bang on 650mhs

If you find any other settings to bring it up to 700+ let me know. But this is after trying hundreds and hundreds of configs, firmwares and driver/api configs as you can see.
Good luck too, and keep an eye on cooling to keep your temps down as these cards will go above 90 even with the cutoff if your cooling isn't up to scratch, and if you have two cards in a case even with the side off.




Offline jackcrowley

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 3
  • Country: 00
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #8 on: December 13, 2013, 11:51:56 PM »
By the way, it is possible to get over 700;
at I 20, concurrency 8191, clock 1053 I got a reliable 700+ locally but if you look at it, it doesn't accept any shares at all. If you work out how to fix that up then you'll be better off.
Other concurrency settings achieved:
24200 - 640-680, accepting lots, 80c temp, stabilises at 650 after a while and tested at 650 for 24 hours
24000 - unstable, fluctuates between 660-730, accepting lots but continues to fluctuate
22000 - 650-680, high temp
8191 - 700, not accepting


Offline jekanev

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #9 on: December 15, 2013, 09:42:31 AM »

"api-allow" : "W:127.0.0.1",
"api-listen" : true,
"expiry" : "1",
"hotplug" : "0",
"kernel-path" : "/usr/local/bin",
"log" : "5",
"no-submit-stale" : true,
"queue" : "1",
"scan-time" : "0",
"scrypt" : true,
"gpu-threads" : "2",
"gpu-engine" : "950,850",
"gpu-memclock" : "1500",
"gpu-powertune" : "-20",
"gpu-vddc" : "0.85",
"intensity" : "13",
"temp-target" : "75",
"temp-overheat" : "80",
"temp-cutoff" : "95",
"temp-hysteresis" : "2",
"worksize" : "256",
"lookup-gap" : "2",
"shaders" : "2048",
"thread-concurrency" : "8192"


core clock with default mem
700 = 480kh/s
850 = 580kh/s
950-970 = 660-680kh/s
975-1000 = 550kh/s sup?
if need 700kh/s speed up memory set 1765 and 1060 core but im get crash.
« Last Edit: December 15, 2013, 09:48:54 AM by jekanev »

Offline xLightcoinx

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #10 on: December 15, 2013, 11:19:28 AM »

Offline slimborama

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #11 on: December 26, 2013, 07:09:42 AM »
I'm having similar problems to the rest of you, and after reading this thread and a few others.  Out of the box, for 1x card with no command line parameters, I was getting 15 kh/s (I had to check my eyes).  With some parameters I grabbed quickly from Litecoin mining hardware comparison site, I was getting 550 kh/s like many of you.  After following xLightcoinx's helpful settings and learning that there's a relationship between engine and memclock, I got the following results:


1x XFX R9 280x OC Black Edition:


Avg 680 kh/s using:


setx GPU_USE_SYNC_OBJECTS=1
setx GPU_MAX_ALLOC_PERCENT=100
cgminer.exe --scrypt -o stratum+tcp://x.x.com:3333 -u x.x -p x -I 13 -g 2 -w 256 --thread-concurrency 8192 --auto-fan --gpu-engine 1026 --gpu-memclock 1498 --gpu-powertune -20 --expiry 1 --scan-time 1 --queue 0 --no-submit-stale




2x XFX R9 280x OC Black Edition:



Avg 610 kh/s using:


setx GPU_USE_SYNC_OBJECTS=1
setx GPU_MAX_ALLOC_PERCENT=100
cgminer.exe --scrypt -o stratum+tcp://x.x.com:3333 -u x.x -p x -I 13 -g 2 -w 256 --thread-concurrency 8192 --auto-fan --gpu-engine 1026,1026 --gpu-memclock 1498,1498 --gpu-powertune -20,-20 --expiry 1 --scan-time 1 --queue 0 --no-submit-stale


Like many of you, I'm also getting a significant drop in both cards as soon as I'm using 2x cards instead of 1x.  I have no idea if this is normal or not.


I purchased 3x cards, but haven't installed the 3rd card yet, pending some more messing around with settings.  I purchased these cards cause they were basically the most expensive versions of the R9 280x and I really liked the cooling power that XFX added.  I was planning on upgrading to Arctic Cooling, which would have added more than the extra cost that these Black Editions added anyway so in the end I thought I was saving some money.  I'm presuming that most (if not all) these manufacturers are using reference designs, so I really don't understand the major performance differences we're seeing.  All I know is, I'm sad.

Offline jonjakejingle

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #12 on: December 26, 2013, 06:15:35 PM »
Thank you @jackcrowley, your config is what I needed. Everyone says do -g 2 but your -g 1 + 24000 concurrency fixed it right up for me. XFX DD Black Edition, getting 675 - 720KH

Offline varchar

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 3
  • Country: 00
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #13 on: December 31, 2013, 04:02:36 PM »
Hi All,


I've got two XFX R9-280X-TDFD in Crossfire. Nothing recommended from above helped me. Got maximum of 640 kH/s.

Here is my method to reach 710kH/s tested for stability:

Prerequisits are Windows x64 8.1, Catalyst 13.12, CGminer 3.7.2.
Step 1: Install latest beta MSI Afterburner from newbielink:http://event.msi.com/vga/afterburner/download.htm [nonactive]. Go to Settings -> Tick "Disable ULPS". Choose Unofficial overclocking mode "without PowerPlay support". Reboot.
Step 2: Install GPU-Z from newbielink:http://www.techpowerup.com/gpuz/ [nonactive]. Save your original BIOS per each card to some secure place.
Step 3: Download BIOS version 40 from newbielink:http://www.techpowerup.com/vgabios/149113/xfx-r9280x-3072-131017.html [nonactive].
Step 4: Download ATI Winflash from newbielink:http://www.techpowerup.com/downloads/2311/ati-winflash-2-6-7/ [nonactive]. Unzip and run command prompt in admin mode. Flash each of your cards with command:
Code: newbielink:javascript:void(0); [nonactive]
atiwinflash -f -p 0 "NAME of the BIOS".rom Where 0 is your card number.
Reboot.
Step 5: Run MSI Afterburner with following settings.
Code: newbielink:javascript:void(0); [nonactive]
Core Volatge: 1100
Power Limit: +20
Core Clock: 1025
Memory Clock: 1500
Fan Speed: Auto + User Define
Hit apply.
Step 6: Create .bat-file to run your CGminer
Code: newbielink:javascript:void(0); [nonactive]
DEL /F /S /Q /A "*.bin"
set GPU_USE_SYNC_OBJECTS=1
set GPU_MAX_ALLOC_PERCENT=100
cgminer --scrypt -u "username" -p "password" -o stratum+tcp://"your_pool_name" -I 13 -g 2 -w 256 --thread-concurrency 8192
Step 7: Open your beer and watch 710 kH/s per each card.  :)

BTW please consider risk of BIOS flashing. Here's reply from XFX support:
Quote
12/29/2013 3:56:27 PM By varchar Type:0
Hi!

Have found a new bios version 015.040.000.001.000000 newbielink:http://www.techpowerup.com/vgabios/149113/xfx-r9280x-3072-131017.html [nonactive] Is it officially supported?

Thank you!
Quote
12/30/2013 3:24:43 AM By wade@pnl Type:2
Dear sir

I don't think it is officially supported.

Please think twice before you use the bios.

Best regards

Wade


If you found this method helpful and want to donate: LTC --- LQLzs3DGvGdB77HK8AzQ7KTGVx9PeGW5Co
« Last Edit: December 31, 2013, 04:19:58 PM by varchar »

Offline xLightcoinx

  • Trade Count: (0)
  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Mining speed too slow with 2x XFX 280x
« Reply #14 on: January 02, 2014, 12:37:48 PM »
Have you tried without crossfire? Crossfire is not recommended when mining as each GPU is a distinct entity unlike when gaming when they work together, I wanted to try it as well but consensus seem it causes more pain than it's worth.

 

How to keep your PC usable while mining full speed.

Started by LouhariBoard Litecoin mining

Replies: 0
Views: 6803
Last post April 05, 2013, 03:56:28 AM
by Louhari
2x Sapphire R9 280X OC Dual-X 3GB mining NEED HELP

Started by RDLTCBoard Litecoin mining

Replies: 2
Views: 8616
Last post December 21, 2013, 01:38:25 PM
by Rosta32
R9 280X mining nicely, HD7970 can't get over 350Kh !?

Started by BenjiTshiBoard Litecoin mining

Replies: 1
Views: 2191
Last post December 16, 2013, 04:55:40 PM
by mugsy
Overclocking XFX & Diamond 280x

Started by zak9494Board Litecoin mining

Replies: 0
Views: 2414
Last post January 24, 2014, 01:37:20 AM
by zak9494
XFX R9 280x DD (TDFD) or Black OC (TDBD) edition undervolting

Started by metraqueBoard Litecoin mining

Replies: 2
Views: 6594
Last post February 06, 2014, 06:44:52 AM
by hash.net